PT-2024-6044

CVE-2024-27088

·

تاريخ النشر

2024-02-26

·

تاريخ التحديث

2025-09-05

الوصف من

CVSS 3.1
5.5
متوسطة
المقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions es5-ext versions prior to 0.10.63
Description The issue is related to the es5-ext package, which contains ECMAScript 5 extensions. Passing functions with very long names or complex default argument names into function#copy or function#toStringTokens may cause the script to stall. This can lead to a denial of service.
Recommendations For versions prior to 0.10.63, update to version 0.10.63 or later to resolve the issue. As a temporary workaround, consider refraining from using the function#copy and function#toStringTokens utilities until a patch is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-4GMJ-3P3H-GM8H
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾