PT-2024-6209
CVE-2024-32608
·
تاريخ النشر
2024-05-14
·
تاريخ التحديث
2024-11-08
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
HDF5 library versions prior to 1.14.4
Description
The issue is related to memory corruption in the
H5A close() function of the HDF5 library, resulting in the corruption of the instruction pointer. This can cause denial of service or potential code execution. The vulnerability is associated with a heap buffer overflow, which can be exploited by a remote attacker to cause a denial of service.Recommendations
For HDF5 library versions prior to 1.14.4, update to version 1.14.4 or later to resolve the issue. As a temporary workaround, consider disabling the
H5A close() function until a patch is available. Restrict access to the HDF5 library to minimize the risk of exploitation. Avoid using the HDF5 library for critical operations until the issue is resolved. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾