PT-2024-7999

CVE-2024-50340

·

تاريخ النشر

2023-10-07

·

تاريخ التحديث

2025-07-01

الوصف من

CVSS 3.1
7.3
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions Symfony versions prior to 5.4.46 Symfony versions prior to 6.4.14 Symfony versions prior to 7.1.7
Description The issue exists due to the lack of measures to neutralize special elements, allowing a remote attacker to execute arbitrary code. When the register argv argc php directive is set to on, and users call any URL with a specially crafted query string, they are able to change the environment or debug mode used by the kernel when handling the request. Over 32,000 results are found to be potentially vulnerable.
Recommendations For versions prior to 5.4.46, update to version 5.4.46 or later. For versions prior to 6.4.14, update to version 6.4.14 or later. For versions prior to 7.1.7, update to version 7.1.7 or later. As a temporary workaround, consider setting the register argv argc php directive to off until a patch is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-X8VP-GF4Q-MW5J
ALT-PU-2023-6184
ALT-PU-2024-1028
ALT-PU-2024-4537
ALT-PU-2024-4547
ALT-PU-2024-4961
ALT-PU-2025-4212
DSA-5809-1
USN-7272-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾