PT-2024-8475

CVE-2024-10220

·

تاريخ النشر

2024-11-20

·

تاريخ التحديث

2024-12-13

الوصف من

CVSS 4.0
8.6
عالية
المقاييسAV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions Kubernetes kubelet versions through 1.28.11 Kubernetes kubelet versions from 1.29.0 through 1.29.6 Kubernetes kubelet versions from 1.30.0 through 1.30.2
Description The issue allows arbitrary command execution via specially crafted gitRepo volumes. This can be leveraged by an attacker to execute commands outside of the container's boundary, potentially leading to a container escape. The vulnerability is related to the hooks folder in the target repository. It is estimated that over 3 million results are affected, and the issue has been identified in various Kubernetes versions.
Recommendations For Kubernetes kubelet versions through 1.28.11, update to version 1.28.12 to resolve the issue. For Kubernetes kubelet versions from 1.29.0 through 1.29.6, update to version 1.29.7 to resolve the issue. For Kubernetes kubelet versions from 1.30.0 through 1.30.2, update to version 1.30.3 to resolve the issue. As a temporary workaround, consider disabling the use of gitRepo volumes until a patch is available. Restrict access to the hooks folder in the target repository to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-27WF-5967-98GX
AZL-53528
AZL-53652
ECHO-8A09-0079-B4FA
GO-2024-3286
MGASA-2024-0389
OESA-2024-2532
OPENSUSE-SU-2024:14567-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾