PT-2026-27037

تاريخ النشر

2026-03-12

·

تاريخ التحديث

2026-03-12

الوصف من

CVSS 3.1
4.6
متوسطة
المقاييسAV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Impact

The Trix editor, in versions prior to 2.1.17, is vulnerable to XSS attacks when a data-trix-serialized-attributes attribute bypasses the DOMPurify sanitizer.
An attacker could craft HTML containing a data-trix-serialized-attributes attribute with a malicious payload that, when the content is rendered, could execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed.

Patches

Update Recommendation: Users should upgrade to Trix editor version 2.1.17 or later.

References

The XSS vulnerability was responsibly reported by Hackerone researcher newbiefromcoma.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-QMPG-8XG6-PH5Q
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾