PT-2026-35634

تاريخ النشر

2026-04-17

·

تاريخ التحديث

2026-04-17

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Summary

Exec environment denylist missed high-risk interpreter startup variables.

Affected Packages / Versions

  • Package: openclaw
  • Ecosystem: npm
  • Affected versions: < 2026.4.10
  • Patched versions: >= 2026.4.10

Impact

The exec environment policy missed interpreter startup variables such as VIMINIT, EXINIT, LUA INIT, and HOSTALIASES, allowing operator-supplied environment overrides to influence downstream execution or network behavior.

Technical Details

The fix expands the host environment security policy denylist to cover these and related high-risk environment variables, with regression coverage.

Fix

The issue was fixed in #63277. The first stable tag containing the fix is v2026.4.10, and openclaw@2026.4.14 includes the fix.

Fix Commit(s)

  • 2d126fc62343a7b6895351f96e4e1474bc358140
  • PR: #63277

Release Process Note

Users should upgrade to openclaw 2026.4.10 or newer. The latest npm release, 2026.4.14, already includes the fix.

Credits

Thanks to @feiyang666 of Tencent zhuque Lab (https://github.com/Tencent/AI-Infra-Guard) for reporting this issue.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-VFP4-8X56-J7C5
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾