PT-2011-1439
CVE-2010-3837
·
Publicado
2010-11-03
·
Atualizado
2019-12-17
Descrição por
CVSS 2.0
4.0
MédiaMétricasAV:N/AC:L/Au:S/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
MySQL versions 5.0 before 5.0.92
MySQL versions 5.1 before 5.1.51
MySQL versions 5.5 before 5.5.6
Description
The issue allows remote authenticated users to cause a denial of service, resulting in a server crash. This is achieved through a prepared statement that utilizes
GROUP CONCAT with the WITH ROLLUP modifier. The probable cause is a use-after-free error, which occurs when a copied object is modified in a way that also affects the original object.Recommendations
For MySQL versions 5.0 before 5.0.92, update to version 5.0.92 or later.
For MySQL versions 5.1 before 5.1.51, update to version 5.1.51 or later.
For MySQL versions 5.5 before 5.5.6, update to version 5.5.6 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾