PT-2011-2566
CVE-2011-0696
·
Publicado
2011-02-14
·
Atualizado
2018-07-23
Descrição por
CVSS 4.0
8.2
AltaMétricasAV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
Django versions 1.1.x through 1.1.3
Django versions 1.2.x through 1.2.4
Description
The issue makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged AJAX requests. This is related to the improper validation of HTTP requests that contain an X-Requested-With header, which can be leveraged by a combination of browser plugins and redirects.
Recommendations
For Django versions 1.1.x through 1.1.3, update to version 1.1.4 or later.
For Django versions 1.2.x through 1.2.4, update to version 1.2.5 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾