PT-2011-4034
CVE-2011-2703
·
Publicado
2011-08-01
·
Atualizado
2021-06-07
Descrição por
CVSS 2.0
7.5
AltaMétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
MapServer versions prior to 4.10.7
MapServer versions 5.x prior to 5.6.7
MapServer versions 6.x prior to 6.0.1
Description
The issue allows remote attackers to execute arbitrary SQL commands. This can be achieved through vectors related to (1) OGC filter encoding or (2) WMS time support.
Recommendations
For MapServer versions prior to 4.10.7, update to version 4.10.7 or later.
For MapServer versions 5.x prior to 5.6.7, update to version 5.6.7 or later.
For MapServer versions 6.x prior to 6.0.1, update to version 6.0.1 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾