PT-2011-4188
CVE-2011-2929
·
Publicado
2011-08-29
·
Atualizado
2019-08-08
Descrição por
CVSS 2.0
5.0
MédiaMétricasAV:N/AC:L/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions 3.0.x through 3.0.9
Ruby on Rails versions 3.1.x through 3.1.0.rc5
Description
The template selection functionality in actionpack/lib/action view/template/resolver.rb does not properly handle glob characters, allowing remote attackers to render arbitrary views via a crafted URL, related to a "filter skipping vulnerability."
Recommendations
For Ruby on Rails versions 3.0.x through 3.0.9, update to version 3.0.10 or later.
For Ruby on Rails versions 3.1.x through 3.1.0.rc5, update to version 3.1.0.rc6 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾