PT-2011-4927
CVE-2011-4315
·
Publicado
2011-12-08
·
Atualizado
2024-06-15
Descrição por
CVSS 2.0
6.8
MédiaMétricasAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
nginx versions prior to 1.0.10
Description
The issue is related to a heap-based buffer overflow in compression-pointer processing. This occurs in the core/ngx resolver.c file of the nginx software. Remote resolvers can potentially cause a denial of service, leading to a daemon crash, or possibly have other unspecified impacts by sending a long response.
Recommendations
For versions prior to 1.0.10, update to version 1.0.10 or later to resolve the issue. As a temporary workaround, consider restricting access to the
core/ngx resolver.c module to minimize the risk of exploitation.Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾