PT-2011-4929
CVE-2011-4319
·
Publicado
2011-11-28
·
Atualizado
2019-08-08
Descrição por
CVSS 2.0
4.3
MédiaMétricasAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions 3.0.x through 3.0.10
Ruby on Rails versions 3.1.x through 3.1.1
Ruby on Rails 2.3.x (with rails xss plugin)
Description
A cross-site scripting (XSS) issue exists due to a flaw in the i18n translations helper method, allowing remote attackers to inject arbitrary web script or HTML via specific vectors related to translations strings.
Recommendations
For Ruby on Rails versions 3.0.x through 3.0.10, update to version 3.0.11 or later.
For Ruby on Rails versions 3.1.x through 3.1.1, update to version 3.1.2 or later.
For Ruby on Rails 2.3.x with the rails xss plugin, consider removing or disabling the plugin until a patch is available.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾