PT-2012-1127
CVE-2012-0815
·
Publicado
2012-04-03
·
Atualizado
2021-08-23
Descrição por
CVSS 2.0
9.3
AltaMétricasAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
RPM versions prior to 4.9.1.3
Description
The issue allows remote attackers to cause a denial of service and possibly execute arbitrary code via a negative value in a region offset of a package header, which is not properly handled in a numeric range comparison. This can lead to a violation of confidentiality, integrity, and availability of protected information. The exploitation of this issue can be done remotely.
Recommendations
For versions prior to 4.9.1.3, update to version 4.9.1.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the
headerVerifyInfo function in lib/header.c until a patch is available.Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾