PT-2012-1130

CVE-2011-2709

·

Publicado

2012-06-21

·

Atualizado

2024-06-15

Descrição por

CVSS 2.0
6.2
Média
MétricasAV:L/AC:H/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions libgssglue versions prior to 0.4 libgssapi versions prior to 0.4
Description The issue concerns a problem with privilege checking in libgssapi and libgssglue, which can be exploited locally. This can lead to the execution of arbitrary code via the GSSAPI MECH CONF environment variable. For example, this can be demonstrated using mount.nfs. The exploitation of this issue may result in a breach of confidentiality, integrity, and availability of protected information.
Recommendations For libgssglue versions prior to 0.4, update to version 0.4 or later to resolve the issue. For libgssapi versions prior to 0.4, update to version 0.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the GSSAPI MECH CONF environment variable to minimize the risk of exploitation.
Explorabilidade
Correção
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
OPENSUSE-SU-2024:10085-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾