PT-2012-1225

CVE-2012-2311

·

Publicado

2012-05-11

·

Atualizado

2024-06-15

Descrição por

CVSS 2.0
7.5
Alta
MétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.3.13 PHP versions 5.4.x prior to 5.4.3
Description The issue is related to the handling of query strings in PHP when configured as a CGI script. Specifically, it does not properly handle query strings that contain a %3D sequence but no = (equals sign) character. This allows remote attackers to execute arbitrary code by placing command-line options in the query string. The problem is due to an incomplete fix for a previous issue.
Recommendations For PHP versions prior to 5.3.13, update to version 5.3.13 or later. For PHP versions 5.4.x prior to 5.4.3, update to version 5.4.3 or later.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
APACHEPHPCGI3DRCECHECK
DSA-2465-1
HPSBUX02791
OPENSUSE-SU-2024:10290-1
OPENSUSE-SU-2024:10344-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾