PT-2012-1240

CVE-2012-0393

·

Publicado

2012-01-02

·

Atualizado

2022-05-04

Descrição por

CVSS 2.0
6.4
Média
MétricasAV:N/AC:L/Au:N/C:N/I:P/A:P
Name of the Vulnerable Software and Affected Versions Apache Struts versions prior to 2.3.1.1
Description The issue is related to the ParameterInterceptor component, which does not properly restrict access to public constructors. This allows remote attackers to create or overwrite arbitrary files by crafting a parameter that triggers the creation of a Java object. The vulnerability is associated with insufficient access control in the ParameterInterceptor component, enabling remote attackers to write arbitrary files to the system.
Recommendations For versions prior to 2.3.1.1, update to version 2.3.1.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the ParameterInterceptor component to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
GHSA-HXQQ-W4MR-MC62
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾