PT-2012-1339
CVE-2010-5096
·
Publicado
2012-08-13
·
Atualizado
2025-09-26
Descrição por
CVSS 2.0
7.5
AltaMétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
MyBB versions prior to 1.6.1
Description
The issue allows remote attackers to execute arbitrary SQL commands via the
keywords parameter in a (1) do search action to "search.php" or (2) do stuff action to "private.php". The vendor disputes this issue, stating it does not lead to an SQL injection but provides a general MyBB SQL error.Recommendations
For versions prior to 1.6.1, update to version 1.6.1 or later to resolve the issue.
As a temporary workaround, consider restricting access to the "search.php" and "private.php" files to minimize the risk of exploitation.
Avoid using the
keywords parameter in the affected API endpoints until the issue is resolved.Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾