PT-2012-4348

CVE-2012-2902

·

Publicado

2012-05-21

·

Atualizado

2017-08-29

Descrição por

CVSS 2.0
6.0
Média
MétricasAV:N/AC:M/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Joomla Content Editor (JCE) component versions prior to 2.1
Description The issue allows remote authors to execute arbitrary PHP code by uploading a PHP file with a double extension. This can be achieved when chunking is set to greater than zero in the editor/extensions/browser/file.php file.
Recommendations For versions prior to 2.1, update to version 2.1 or later to resolve the issue. As a temporary workaround, consider restricting file uploads or disabling the chunking feature in the editor/extensions/browser/file.php file until a patch is available. Restrict access to the file.php module to minimize the risk of exploitation. Avoid using double extensions in file uploads until the issue is resolved.
Explorabilidade
Correção
Fornecedores
Produtos afetados
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾