PT-2012-5401
CVE-2012-4436
·
Publicado
2012-10-22
·
Atualizado
2012-11-08
Descrição por
CVSS 2.0
4.4
MédiaMétricasAV:L/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
fwknop versions prior to 2.0.3
Description
The issue is related to a buffer overflow in the
run last args function, which can occur when processing the --last option with many .fwknop.run arguments. This might allow local users to cause a denial of service, resulting in a client crash, and potentially execute arbitrary code.Recommendations
For versions prior to 2.0.3, update to version 2.0.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
--last option and limiting the number of .fwknop.run arguments to minimize the risk of exploitation.Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾