PT-2013-1058

CVE-2013-1985

·

Publicado

2013-06-15

·

Atualizado

2024-06-15

Descrição por

CVSS 2.0
6.8
Média
MétricasAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions libXinerama versions 1.1.2 and earlier xorg-server versions prior to 1.14.3-r2 libXext versions 1.3.2 and earlier libX11 versions 1.6.0 and earlier libXt versions 1.1.4 and earlier libXfixes versions 5.0.1 and earlier libXinerama-devel versions 1.1.3 and earlier libXrandr versions 1.4.1 and earlier libXrender versions 0.9.8 and earlier libXi versions 1.7.2 and earlier libXres versions 1.0.7 and earlier libXv versions 1.0.9 and earlier libXxf86vm versions 1.1.3 and earlier libXcursor versions 1.1.14 and earlier libXtst versions 1.2.2 and earlier libXvMC versions 1.0.8 and earlier libX11-common versions 1.6.0 and earlier libxinerama (affected versions not specified) libXcursor-devel versions 1.1.14 and earlier libXrender versions 0.9.8 and earlier libXtst-debuginfo versions 1.2.2 and earlier
Description The issue is related to multiple vulnerabilities in various packages of the Red Hat Enterprise Linux and Gentoo Linux operating systems. These vulnerabilities can lead to a breach of confidentiality, integrity, and availability of protected information. The vulnerabilities can be exploited remotely. An integer overflow in X.org libXinerama 1.1.2 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the XineramaQueryScreens function.
Recommendations For libXinerama versions 1.1.2 and earlier, update to a version later than 1.1.2. For xorg-server versions prior to 1.14.3-r2, update to version 1.14.3-r2 or later. For libXext versions 1.3.2 and earlier, update to a version later than 1.3.2. For libX11 versions 1.6.0 and earlier, update to a version later than 1.6.0. For libXt versions 1.1.4 and earlier, update to a version later than 1.1.4. For libXfixes versions 5.0.1 and earlier, update to a version later than 5.0.1. For libXinerama-devel versions 1.1.3 and earlier, update to a version later than 1.1.3. For libXrandr versions 1.4.1 and earlier, update to a version later than 1.4.1. For libXrender versions 0.9.8 and earlier, update to a version later than 0.9.8. For libXi versions 1.7.2 and earlier, update to a version later than 1.7.2. For libXres versions 1.0.7 and earlier, update to a version later than 1.0.7. For libXv versions 1.0.9 and earlier, update to a version later than 1.0.9. For libXxf86vm versions 1.1.3 and earlier, update to a version later than 1.1.3. For libXcursor versions 1.1.14 and earlier, update to a version later than 1.1.14. For libXtst versions 1.2.2 and earlier, update to a version later than 1.2.2. For libXvMC versions 1.0.8 and earlier, update to a version later than 1.0.8. For libX11-common versions 1.6.0 and earlier, update to a version later than 1.6.0. For libxinerama, update to a version that is not vulnerable. For libXcursor-devel versions 1.1.14 and earlier, update to a version later than 1.1.14. For libXrender versions 0.9.8 and earlier, update to a version later than 0.9.8. For libXtst-debuginfo versions 1.2.2 and earlier, update to a version later than 1.2.2.
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾