PT-2013-1212

CVE-2013-0211

·

Publicado

2013-03-25

·

Atualizado

2024-06-15

Descrição por

CVSS 2.0
7.5
Alta
MétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions libarchive versions prior to 3.1.2
Description The issue is related to multiple vulnerabilities in the libarchive package, which can be exploited to compromise the confidentiality, integrity, and availability of protected information. Exploitation can occur remotely. Specifically, an integer signedness error in the archive write zip data function in archive write set format zip.c can cause a denial of service (crash) on 64-bit machines due to an improper conversion between unsigned and signed types, leading to a buffer overflow.
Recommendations For versions prior to 3.1.2, update to version 3.1.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the archive write zip data function to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2015-1654
FREEBSD-SA-16_23
OPENSUSE-SU-2024:10127-1
SUSE-SU-2015:0667-1
SUSE-SU-2015_0667-1
USN-2549-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾