PT-2013-1889

CVE-2012-6099

·

Publicado

2013-01-27

·

Atualizado

2022-05-13

Descrição por

CVSS 2.0
4.0
Média
MétricasAV:N/AC:L/Au:S/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Moodle versions 2.1.x through 2.1.9 Moodle versions 2.2.x through 2.2.6 Moodle versions 2.3.x through 2.3.3 Moodle versions 2.4.x through 2.4.0
Description The issue is related to the moodle1 backup converter in Moodle, which does not properly validate pathnames. This allows remote authenticated users to read arbitrary files by leveraging the backup-restoration feature.
Recommendations For Moodle versions 2.1.x through 2.1.9, update to version 2.1.10 or later. For Moodle versions 2.2.x through 2.2.6, update to version 2.2.7 or later. For Moodle versions 2.3.x through 2.3.3, update to version 2.3.4 or later. For Moodle versions 2.4.x through 2.4.0, update to version 2.4.1 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
GHSA-CR78-RPHW-W73P
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾