PT-2013-3288

CVE-2013-1630

·

Publicado

2013-08-06

·

Atualizado

2022-05-17

Descrição por

CVSS 4.0
8.2
Alta
MétricasAV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions pyshop versions prior to 0.7.1
Description The issue allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a download operation, as it uses HTTP to retrieve packages from the PyPI repository and does not perform integrity checks on package contents.
Recommendations For versions prior to 0.7.1, update to version 0.7.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the PyPI repository or using a secure connection to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
GHSA-F594-F3V3-G649
PYSEC-2013-10
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾