PT-2013-3289
CVE-2013-1633
·
Publicado
2013-08-06
·
Atualizado
2022-05-17
Descrição por
CVSS 3.1
8.3
AltaMétricasAV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
setuptools versions prior to 0.7
Description
The issue allows man-in-the-middle attackers to execute arbitrary code via a crafted response. This is due to the use of HTTP to retrieve packages from the PyPI repository and the lack of integrity checks on package contents.
Recommendations
For versions prior to 0.7, update to version 0.7 or later to resolve the issue. As a temporary workaround, consider using a secure connection to retrieve packages, such as HTTPS, to minimize the risk of exploitation. Restrict access to the
easy install function until a patch is available.Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾