PT-2013-3401

CVE-2013-1802

·

Publicado

2013-04-09

·

Atualizado

2017-10-24

Descrição por

CVSS 2.0
7.5
Alta
MétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions extlib gem versions 0.9.15 and earlier
Description The issue is related to the improper restriction of casts of string values, which could allow remote attackers to conduct object-injection attacks, execute arbitrary code, or cause a denial of service by consuming memory and CPU. This is achieved by leveraging Action Pack support for YAML type conversion or Symbol type conversion.
Recommendations For extlib gem versions 0.9.15 and earlier, update to a version later than 0.9.15 to resolve the issue.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-9H36-4JF2-HX53
DLA-172-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾