PT-2013-4901

CVE-2013-4212

·

Publicado

2013-12-07

·

Atualizado

2017-08-29

Descrição por

CVSS 2.0
6.8
Média
MétricasAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Apache Roller versions prior to 5.0.2
Description The issue allows remote attackers to execute arbitrary OGNL expressions via certain parameters, such as the pageTitle parameter in the !getPageTitle sub-URL to roller-ui/login.rol. This is possible due to certain getText methods in the ActionSupport controller.
Recommendations For Apache Roller versions prior to 5.0.2, update to version 5.0.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the roller-ui/login.rol URL and its subclasses, such as UIAction, to minimize the risk of exploitation. Avoid using the pageTitle parameter in the !getPageTitle sub-URL until the issue is resolved.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾