PT-2013-4974
CVE-2013-4363
·
Publicado
2013-10-09
·
Atualizado
2025-09-29
Descrição por
CVSS 2.0
4.3
MédiaMétricasAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
RubyGems versions 1.8.24 through 1.8.26
RubyGems versions prior to 1.8.23.2
RubyGems versions 2.0.x prior to 2.0.10
RubyGems versions 2.1.x prior to 2.1.5
Description
The issue is related to an algorithmic complexity vulnerability in
Gem::Version::ANCHORED VERSION PATTERN in lib/rubygems/version.rb. This vulnerability allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.Recommendations
For RubyGems versions 1.8.24 through 1.8.26, update to a version outside of this range to resolve the issue.
For RubyGems versions prior to 1.8.23.2, update to version 1.8.23.2 or later to resolve the issue.
For RubyGems versions 2.0.x prior to 2.0.10, update to version 2.0.10 or later to resolve the issue.
For RubyGems versions 2.1.x prior to 2.1.5, update to version 2.1.5 or later to resolve the issue.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾