PT-2013-5118

CVE-2013-4660

·

Publicado

2013-06-28

·

Atualizado

2025-12-02

Descrição por

CVSS 2.0
6.8
Média
MétricasAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions js-yaml versions 2.0.4 and earlier
Description The issue allows remote attackers to execute arbitrary code via a crafted string that triggers an eval operation, due to the JS-YAML module parsing input without properly considering the unsafe !!js/function tag.
Recommendations Update to version 2.0.5 or later, and ensure that all instances where the load() method is called are updated to use safeLoad() instead.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
GHSA-XXVW-45RP-3MJ2
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾