PT-2013-6038
CVE-2013-6415
·
Publicado
2013-12-07
·
Atualizado
2019-08-08
Descrição por
CVSS 2.0
4.3
MédiaMétricasAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions prior to 3.2.16
Ruby on Rails versions 4.x prior to 4.0.2
Description
A cross-site scripting (XSS) issue exists in the number to currency helper, allowing remote attackers to inject arbitrary web script or HTML via the
unit parameter. This enables attackers to execute malicious scripts on the client-side.Recommendations
For Ruby on Rails versions prior to 3.2.16, update to version 3.2.16 or later.
For Ruby on Rails versions 4.x prior to 4.0.2, update to version 4.0.2 or later.
As a temporary workaround, consider restricting the use of the
number to currency helper until a patch is applied.Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾