PT-2014-1437

CVE-2014-0231

·

Publicado

2014-07-14

·

Atualizado

2024-06-15

Descrição por

CVSS 2.0
5.0
Média
MétricasAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions prior to 2.4.10
Description The issue is related to the mod cgid module, which lacks a timeout mechanism. This allows remote attackers to cause a denial of service (process hang) by sending a request to a CGI script that does not read from its stdin file descriptor. A flaw in mod cgid can cause child processes to hang indefinitely if a server hosts CGI scripts that do not consume standard input, leading to denial of service.
Recommendations For versions prior to 2.4.10, update to version 2.4.10 or later to resolve the issue. As a temporary workaround, consider restricting access to CGI scripts that do not consume standard input to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
ALT-PU-2016-1385
CESA-2014_0920
CESA-2014_0921
DLA-66-1
DSA-2989-1
HPSBUX03337
HPSBUX03512
MGASA-2014-0304
MGASA-2014-0305
OPENSUSE-SU-2014_0969-1
OPENSUSE-SU-2024:10268-1
RHSA-2014:0920
RHSA-2014_0920
RHSA-2014:0921
RHSA-2014_0921
RHSA-2014:0922
RHSA-2014:1019
RHSA-2014:1020
RHSA-2014:1087
RHSA-2014:1088
SUSE-SU-2015:0689-1
USN-2299-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾