PT-2014-1757
CVE-2014-5165
·
Publicado
2014-08-01
·
Atualizado
2024-06-15
Descrição por
CVSS 2.0
5.0
MédiaMétricasAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
Wireshark versions 1.10.x through 1.10.8
Description
The issue exists in the
dissect ber constrained bitstring function due to incorrect validation of padding values in the ASN.1 BER dissector. This allows remote attackers to cause a denial of service, resulting in a buffer underflow and application crash, by sending a specially crafted packet.Recommendations
For Wireshark versions 1.10.x through 1.10.8, update to version 1.10.9 or later to resolve the issue. As a temporary workaround, consider restricting access to the
dissect ber constrained bitstring function in the ASN.1 BER dissector to minimize the risk of exploitation.Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾