PT-2014-2047
CVE-2015-0231
·
Publicado
2014-12-30
·
Atualizado
2024-06-15
Descrição por
CVSS 2.0
7.5
AltaMétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions 5.4.x through 5.4.36
PHP versions 5.5.x through 5.5.20
PHP versions 5.6.x through 5.6.4
Description
The issue is related to a use-after-free vulnerability in the
process nested data function in ext/standard/var unserializer.re in PHP. This vulnerability allows remote attackers to execute arbitrary code via a crafted unserialize call that leverages improper handling of duplicate numerical keys within the serialized properties of an object.Recommendations
For PHP versions 5.4.x through 5.4.36, update to version 5.4.37 or later.
For PHP versions 5.5.x through 5.5.20, update to version 5.5.21 or later.
For PHP versions 5.6.x through 5.6.4, update to version 5.6.5 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾