PT-2014-2062

CVE-2004-2771

·

Publicado

2014-12-16

·

Atualizado

2026-09-23

Descrição por

CVSS 2.0
7.5
Alta
MétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Heirloom mailx versions 12.5 and earlier BSD mailx versions 8.1.2 and earlier
Description The issue allows remote attackers to execute arbitrary commands via shell metacharacters in an email address, specifically through the expand function in fio.c.
Recommendations For Heirloom mailx versions 12.5 and earlier, update to a version later than 12.5 to resolve the issue. For BSD mailx versions 8.1.2 and earlier, update to a version later than 8.1.2 to resolve the issue. As a temporary workaround, consider restricting the use of email addresses that may contain shell metacharacters until a patch is available.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
AZL-36961
AZL-6676
AZL-7286
CESA-2014_1999
DLA-114-1
DSA-3105-1
MGASA-2014-0538
OPENSUSE-SU-2024:10561-1
RHSA-2014:1999
RHSA-2014_1999
SUSE-RU-2015:0876-1
SUSE-SU-2014_1658-1
SUSE-SU-2014_1696-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾