PT-2014-2111
CVE-2011-1749
·
Publicado
2011-12-05
·
Atualizado
2014-03-10
Descrição por
CVSS 2.0
3.3
BaixaMétricasAV:L/AC:M/Au:N/C:N/I:P/A:P
Name of the Vulnerable Software and Affected Versions
nfs-utils versions prior to 1.2.4
Description
The issue allows local users to corrupt the /etc/mtab file via a process with a small RLIMIT FSIZE value. This occurs because the nfs addmntent function in the mount.nsf tool attempts to append to the /etc/mtab file without first checking whether resource limits would interfere.
Recommendations
For versions prior to 1.2.4, update to version 1.2.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the mount.nsf tool to minimize the risk of exploitation. Avoid using the nfs addmntent function in the mount.nsf tool until the issue is resolved.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾