PT-2014-4779

CVE-2014-2558

·

Publicado

2014-05-06

·

Atualizado

2014-05-07

Descrição por

CVSS 2.0
6.5
Média
MétricasAV:N/AC:L/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions File Gallery plugin versions prior to 1.7.9.2
Description The issue allows remote administrators to execute arbitrary PHP code due to improper string escaping in the setting fields. This can be achieved by injecting a backslash quote in the setting fields to the /wp-admin/options-media.php endpoint, related to the create function function.
Recommendations For versions prior to 1.7.9.2, update to version 1.7.9.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the /wp-admin/options-media.php endpoint to minimize the risk of exploitation. Avoid using the backslash quote character in the setting fields until the issue is resolved.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾