PT-2014-4784
CVE-2014-2571
·
Publicado
2014-03-22
·
Atualizado
2022-05-13
Descrição por
CVSS 2.0
3.5
BaixaMétricasAV:N/AC:M/Au:S/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Moodle versions prior to 2.3.11
Moodle versions 2.4.x before 2.4.9
Moodle versions 2.5.x before 2.5.5
Moodle versions 2.6.x before 2.6.2
Description
A cross-site scripting (XSS) issue exists in the quiz question tostring function in mod/quiz/editlib.php, allowing remote authenticated users to inject arbitrary web script or HTML via a quiz question.
Recommendations
For Moodle versions prior to 2.3.11, update to version 2.3.11 or later.
For Moodle versions 2.4.x before 2.4.9, update to version 2.4.9 or later.
For Moodle versions 2.5.x before 2.5.5, update to version 2.5.5 or later.
For Moodle versions 2.6.x before 2.6.2, update to version 2.6.2 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾