PT-2014-5380
CVE-2014-3542
·
Publicado
2014-07-29
·
Atualizado
2022-05-13
Descrição por
CVSS 2.0
4.3
MédiaMétricasAV:N/AC:M/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Moodle versions 2.3.11 and earlier, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, 2.7.x before 2.7.1
Description
The issue allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue. This occurs in the mod/lti/service.php file.
Recommendations
For versions 2.3.11 and earlier, update to a version later than 2.3.11.
For versions 2.4.x before 2.4.11, update to version 2.4.11 or later.
For versions 2.5.x before 2.5.7, update to version 2.5.7 or later.
For versions 2.6.x before 2.6.4, update to version 2.6.4 or later.
For versions 2.7.x before 2.7.1, update to version 2.7.1 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾