PT-2014-5389
CVE-2014-3551
·
Publicado
2014-07-29
·
Atualizado
2022-05-13
Descrição por
CVSS 2.0
3.5
BaixaMétricasAV:N/AC:M/Au:S/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Moodle versions prior to 2.3.11
Moodle versions 2.4.x before 2.4.11
Moodle versions 2.5.x before 2.5.7
Moodle versions 2.6.x before 2.6.4
Moodle versions 2.7.x before 2.7.1
Description
The issue allows remote authenticated users to inject arbitrary web script or HTML via crafted fields in a rubric, specifically the qualification or rating field. This is due to multiple cross-site scripting (XSS) vulnerabilities in the advanced-grading implementation.
Recommendations
For Moodle versions prior to 2.3.11, update to version 2.3.11 or later.
For Moodle versions 2.4.x before 2.4.11, update to version 2.4.11 or later.
For Moodle versions 2.5.x before 2.5.7, update to version 2.5.7 or later.
For Moodle versions 2.6.x before 2.6.4, update to version 2.6.4 or later.
For Moodle versions 2.7.x before 2.7.1, update to version 2.7.1 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾