PT-2014-5408
CVE-2014-3591
·
Publicado
2014-12-31
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
4.2
MédiaMétricasAV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Libgcrypt versions prior to 1.6.3
GnuPG versions prior to 1.4.19
Description
The issue concerns the lack of ciphertext blinding for Elgamal decryption, allowing physically proximate attackers to obtain the server's private key. This is achieved by determining factors using crafted ciphertext and analyzing the fluctuations in the electromagnetic field during multiplication.
Recommendations
For Libgcrypt versions prior to 1.6.3, update to version 1.6.3 or later to resolve the issue.
For GnuPG versions prior to 1.4.19, update to version 1.4.19 or later to resolve the issue.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾