PT-2014-5620
CVE-2014-3940
·
Publicado
2014-06-05
·
Atualizado
2021-07-15
Descrição por
CVSS 2.0
4.0
MédiaMétricasAV:L/AC:H/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 3.14.5
Description
The issue allows local users to cause a denial of service, resulting in memory corruption or system crash, by accessing certain memory locations. This can be achieved by triggering a race condition via numa maps read operations during hugepage migration. The problem is related to the fs/proc/task mmu.c and mm/mempolicy.c files.
Recommendations
For Linux kernel versions prior to 3.14.5, update to version 3.14.5 or later to resolve the issue. As a temporary workaround, consider restricting access to hugepage migration to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾