PT-2014-8297

CVE-2014-7830

·

Publicado

2014-11-22

·

Atualizado

2022-05-13

Descrição por

CVSS 2.0
3.5
Baixa
MétricasAV:N/AC:M/Au:S/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Moodle versions prior to 2.4.12 Moodle versions 2.5.x before 2.5.9 Moodle versions 2.6.x before 2.6.6 Moodle versions 2.7.x before 2.7.3
Description A cross-site scripting (XSS) issue exists in the Feedback module of Moodle, allowing remote authenticated users to inject arbitrary web script or HTML. This is achieved by leveraging the mod/feedback:mapcourse capability to provide a searchcourse parameter in the mod/feedback/mapcourse.php file.
Recommendations For Moodle versions prior to 2.4.12, update to version 2.4.12 or later. For Moodle versions 2.5.x before 2.5.9, update to version 2.5.9 or later. For Moodle versions 2.6.x before 2.6.6, update to version 2.6.6 or later. For Moodle versions 2.7.x before 2.7.3, update to version 2.7.3 or later. As a temporary workaround, consider restricting access to the mod/feedback/mapcourse.php file until a patch is applied.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-J4MR-VC54-H5PC
MGASA-2014-0483
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾