PT-2014-8816

CVE-2014-9087

·

Publicado

2014-11-26

·

Atualizado

2024-06-15

Descrição por

CVSS 2.0
7.5
Alta
MétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Libksba versions prior to 1.3.2
Description The issue allows remote attackers to cause a denial of service (crash) via a crafted OID in a S/MIME message or ECC based OpenPGP data, which triggers a buffer overflow. This occurs due to an integer underflow in the ksba oid to str function.
Recommendations For versions prior to 1.3.2, update to version 1.3.2 or later to resolve the issue. As a temporary workaround, consider restricting the processing of S/MIME messages and ECC based OpenPGP data to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
DLA-141-1
DSA-3078-1
MGASA-2014-0498
OPENSUSE-SU-2024:10126-1
SUSE-SU-2014_1676-1
SUSE-SU-2015_0030-1
USN-2427-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾