PT-2015-1559
CVE-2015-3258
·
Publicado
2015-06-26
·
Atualizado
2024-06-15
Descrição por
CVSS 2.0
7.5
AltaMétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
cups-filters versions prior to 1.0.70
Description
The issue is caused by a heap-based buffer overflow in the WriteProlog function of the cups-filters package, which can be exploited by a remote attacker to execute arbitrary code or cause a denial of service using a specially crafted print job. The vulnerability is triggered by a small line size in a print job.
Recommendations
For cups-filters versions prior to 1.0.70, update to version 1.0.70 or later to resolve the issue. As a temporary workaround, consider restricting access to the print job functionality to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾