PT-2015-3427

CVE-2015-4021

·

Publicado

2015-05-18

·

Atualizado

2019-04-22

Descrição por

CVSS 2.0
5.0
Média
MétricasAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.4.41 PHP versions 5.5.x prior to 5.5.25 PHP versions 5.6.x prior to 5.6.9
Description The issue is related to errors in number processing in the phar parse tarfile function. It allows remote attackers to cause a denial of service, resulting in integer underflow and memory corruption, via a crafted entry in a tar archive.
Recommendations For PHP versions prior to 5.4.41, update to version 5.4.41 or later. For PHP versions 5.5.x prior to 5.5.25, update to version 5.5.25 or later. For PHP versions 5.6.x prior to 5.6.9, update to version 5.6.9 or later.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
CESA-2015_1135
CESA-2015_1218
DLA-307-1
DSA-3280-1
MGASA-2015-0231
RHSA-2015:1135
RHSA-2015_1135
RHSA-2015:1186
RHSA-2015:1187
RHSA-2015:1218
RHSA-2015_1218
RHSA-2015:1219
SUSE-SU-2015:1253-1
SUSE-SU-2015:1253-2
SUSE-SU-2016:1638-1
USN-2658-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾