PT-2015-3430

CVE-2015-4025

·

Publicado

2015-05-18

·

Atualizado

2019-04-22

Descrição por

CVSS 2.0
7.5
Alta
MétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.4.41 PHP versions 5.5.x prior to 5.5.25 PHP versions 5.6.x prior to 5.6.9
Description The issue is related to an error in handling file paths containing the x00 character. This can allow a remote attacker to gain unauthorized access to files or directories. The vulnerability can be exploited by providing a crafted argument to functions such as set include path, tempnam, rmdir, or readlink.
Recommendations For PHP versions prior to 5.4.41, update to version 5.4.41 or later. For PHP versions 5.5.x prior to 5.5.25, update to version 5.5.25 or later. For PHP versions 5.6.x prior to 5.6.9, update to version 5.6.9 or later.
Explorabilidade
Correção
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
CESA-2015_1135
DLA-307-1
DSA-3280-1
MGASA-2015-0231
RHSA-2015:1135
RHSA-2015_1135
RHSA-2015:1186
RHSA-2015:1187
RHSA-2015:1219
SUSE-SU-2017:3277-1
USN-2658-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾