PT-2015-3432

CVE-2015-4147

·

Publicado

2015-06-09

·

Atualizado

2018-01-05

Descrição por

CVSS 2.0
7.5
Alta
MétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.4.39 PHP versions 5.5.x prior to 5.5.23 PHP versions 5.6.x prior to 5.6.7
Description The issue is related to a "type confusion" problem in the SoapClient:: call method, which does not properly verify the data type of default headers, allowing remote attackers to execute arbitrary code by providing crafted serialized data. This is a result of an error in data processing.
Recommendations For PHP versions prior to 5.4.39, update to version 5.4.39 or later. For PHP versions 5.5.x prior to 5.5.23, update to version 5.5.23 or later. For PHP versions 5.6.x prior to 5.6.7, update to version 5.6.7 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
CESA-2015_1135
CESA-2015_1218
DLA-307-1
RHSA-2015:1053
RHSA-2015:1066
RHSA-2015:1135
RHSA-2015_1135
RHSA-2015:1218
RHSA-2015_1218
USN-2658-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾