PT-2015-3442

CVE-2015-5209

·

Publicado

2015-09-06

·

Atualizado

2022-05-14

Descrição por

CVSS 2.0
7.8
Alta
MétricasAV:N/AC:L/Au:N/C:N/I:C/A:N
Name of the Vulnerable Software and Affected Versions Apache Struts versions prior to 2.3.24.1
Description The issue is related to the implementation of the ValueStack interface in the Apache Struts platform, specifically with insufficient input validation when handling objects with the top parameter. This can be exploited by a remote attacker to gain read, modify, or delete access to data. The top object, which represents the root of the execution context, can be manipulated to alter user sessions or affect container settings.
Recommendations For Apache Struts versions prior to 2.3.24.1, update to version 2.3.24.1 or later to resolve the issue. As a temporary workaround, consider applying a better regex pattern to exclude request parameters that attempt to use the top object, until a patch is applied.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
GHSA-4QGJ-9MVG-3929
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾