PT-2015-3678

CVE-2014-10034

·

Publicado

2015-01-13

·

Atualizado

2017-09-08

Descrição por

CVSS 2.0
6.5
Média
MétricasAV:N/AC:L/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions couponPHP versions prior to 1.2.0
Description The issue concerns SQL injection vulnerabilities in the admin area. These vulnerabilities allow remote administrators to execute arbitrary SQL commands. The vulnerabilities are specifically related to the iDisplayLength and iDisplayStart parameters in the API endpoints "comments paginate.php" and "stores paginate.php" located in "admin/ajax/".
Recommendations For versions prior to 1.2.0, update to version 1.2.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the "comments paginate.php" and "stores paginate.php" files in "admin/ajax/" to minimize the risk of exploitation. Avoid using the iDisplayLength and iDisplayStart parameters in the affected API endpoints until the issue is resolved.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾