PT-2015-4175

CVE-2014-9277

·

Publicado

2014-12-03

·

Atualizado

2015-01-06

Descrição por

CVSS 2.0
7.5
Alta
MétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions MediaWiki versions prior to 1.19.22 MediaWiki versions 1.20.x through 1.22.x before 1.22.14 MediaWiki versions 1.23.x before 1.23.7
Description The issue allows remote attackers to conduct PHP object injection attacks via a crafted string containing <cross-domain-policy> in a PHP format request. This occurs because the wfMangleFlashPolicy function in OutputHandler.php causes the string length to change when converting the request to <NOT-cross-domain-policy>.
Recommendations For MediaWiki versions prior to 1.19.22, update to version 1.19.22 or later. For MediaWiki versions 1.20.x through 1.22.x before 1.22.14, update to version 1.22.14 or later. For MediaWiki versions 1.23.x before 1.23.7, update to version 1.23.7 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2014-2433
DSA-3100-1
MGASA-2014-0506
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾