PT-2015-4539

CVE-2015-0244

·

Publicado

2015-02-05

·

Atualizado

2024-06-15

Descrição por

CVSS 3.1
9.8
Crítica
MétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PostgreSQL versions 9.0.0 through 9.0.18 PostgreSQL versions 9.1.x before 9.1.15 PostgreSQL versions 9.2.x before 9.2.10 PostgreSQL versions 9.3.x before 9.3.6 PostgreSQL versions 9.4.x before 9.4.1
Description The issue arises from improper error handling while reading a protocol message, allowing remote attackers to conduct SQL injection attacks via crafted binary data in a parameter. This is achieved by causing an error, which triggers the loss of synchronization and part of the protocol message to be treated as a new message. This can be demonstrated by causing a timeout or query cancellation.
Recommendations For PostgreSQL versions 9.0.0 through 9.0.18, update to version 9.0.19 or later. For PostgreSQL versions 9.1.x before 9.1.15, update to version 9.1.15 or later. For PostgreSQL versions 9.2.x before 9.2.10, update to version 9.2.10 or later. For PostgreSQL versions 9.3.x before 9.3.6, update to version 9.3.6 or later. For PostgreSQL versions 9.4.x before 9.4.1, update to version 9.4.1 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
CESA-2015_0750
DLA-152-1
DSA-3155-1
MGASA-2015-0069
OPENSUSE-SU-2024:10256-1
RHSA-2015:0699
RHSA-2015:0750
RHSA-2015_0750
RHSA-2015:0856
SUSE-SU-2015:0478-1
USN-2499-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾